Telegram专用的代理工具-MTProxy

富强 小美 4803℃ 1评论

相信好多朋友都对Telegram有所了解,Telegram简称TG,是一款轻量跨平台即时通信软件,今天介绍一款专为TG设计的代理软件 ,相对于使用其他代理软件(如SS和VPN什么的),然后 Telegram 配置链接本地代理软件而言,该方法更方便一些,无需每次启动 Telegram 都需要先启动代理软件,特别是对于手机使用者来说。

下载使用Telegram文章:使用Telegram进行聊天

优点说明

  • 移动设备便捷性:对于电脑用户来说, MTProxy 比较鸡肋,因为很多人都是代理软件开机启动并且全天不关。但是对于手机用户来说,每次要查看 Telegram 客户端,都需要先开启代理软件,而如果你在手机上不是经常要挂代理,但是你会经常去 Telegram 里吹比打屁,那么你就很适合使用 MTProxy 了,它可以让你使用 Telegram 客户端像使用国内的 QQ、微信一样方便,打开即用。
  • 适合分享给朋友:当你觉得 TG很好用,想要劝身边的朋友抛弃 QQ、微信 转投 Telegram 时,你却发现你还需要给他配置一套代理软件、代理账号,指导他如何使用代理软件,巴拉巴拉的。但是如果你有 MTProxy 代理账号,那么只需要填写代理配置后,即可直接使用!

安装教程

系统要求:CentOS 7 / Debian 7+ / Ubuntu 14.04 (推荐 Debian 7/8 x64)

安装脚本

在xshell或是putty里输入以上脚本后回车后会出现菜单,选择1回车。

 mtproxy管理

进入下载脚本的目录并运行脚本进行管理:

运行以上sh会出现以下管理界面:

可以按照以上的选项对MTProxy进行管理。

其他相关管理命令

 Windows使用教程

自动配置

  • 把你的TG更新到最新的版本,打开客户端登陆,
  • 把你安装mtproxy得到的“https://t.me/proxy?server=xxxxxx”复制到浏览器里回车,然后浏览器会自动调用 Telegram 客户端。

手动配置

  • 点击 Telegram 客户端左上角的 三横杠 按钮,
  • 然后点击 你的头像 就会进入保存消息聊天窗口中(在这里发只会被自己看到,而且正好保存起来),
  • 接着复制 tg://proxy?xxxx… 并发送,
  • 最后点击 tg://proxy?xxxx… 链接后就会提示你是否要启用这个代理,点击 启用 按钮,
  • 就会发现自动添加并使用该代理配置了。

配置图解

MTProxy

 

安装过程中报错解决办法

1、提示错误包含

 

当你安装 MTProxy 出现编译错误,并且编译错误信息中包含的有  ccl: error: unrecognized command line option "-std=gnu11" 类似内容(往往在编译错误这几个字的上方几条内),则说明是系统的 OpenSSL 版本过低,不支持部分编译参数。

出现这个错误基本上就是用了老旧的系统,例如:CentOS6 Debian6 Ubuntu12

解决方法有两种:

  • 手动升级 OpenSSL (不推荐,依赖结构复杂)。
  • 更换为更高版本的系统。

2、启动失败,日志提示 ‘S’ option requires exactly 32 hex digits 错误

该问题只出现于自定义密码时,因为 MTProxy 为了安全性而要求密码必须是 32位(多了少了都不行),如果数量不对就会提示这个,建议用脚本随机生成!

 

转载请注明:迷路小孩 » Telegram专用的代理工具-MTProxy

喜欢 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)个小伙伴在吐槽